AE plugin not working

Using the latest 17.5.1 build 47 of AE and Lottie Version: 0.1.21.
I get the attached errors trying to write log files repeatedly.
Yes, I changed the script prefs.
Screen Shot 2020-11-24 at 11.58.41 AM

Hello Kory,

It’s may your system [OS] problem.

Could you explain? I’ve tried on both my Windows 10 machine and my Mac. Doesn’t work on either.

It might be that you do not have access to the location that AE is attempting to write the logs to, and perhaps a solution is to grant write access to that location (In this case /Documents/Adobe/After Effects/AE Project Logs).

OK, how do I do that on a mac? I’ve already set the preference to allow scripts to write to the disk.

OK, I’m a fairly bright guy, won 3 emmy’s, worked on Star Wars, graphics for 6 superbowls, but I have no idea what’s going on here. Lottiefiles plugin for AE does not work with AE 17.5.1 on a mac running OS 10.14.6.
Is there anyone that does tech support here?


Hey Kory,

  1. In the Finder, navigate to the problematic folder (AE Project Logs). Right-click and go to Get Info.

  2. Under Sharing & Permissions, update the Privilege to Read & Write for your user.

Let us know if this works or not. Our fingers are crossed

Thanks for the response. Yes, I had already checked that but double checked and set it to read write for everyone just to be safe. No change.
The plugin seems to process a couple frames and then I get the same error each time but the name of the log file is changing. So it’s permission to the log file, not the folder that’s the issue. It’s like the log file isn’t closing fast enough and it’s trying to write to an open file.

Hey there Kory. Just wondering if this issue happens when you add to the render queue via After Effects as well?

Nope. Never had an issue with AE or Media Composer rendering. I rendered out a couple different size jpg/png sequences thinking it might be a size issue and they rendered fine.
Can’t believe no one else is having this issue. :frowning:
thanks for getting back to me.

This definitely is an interesting one. If you don’t mind, would you consider emailing the .aep file to so we can have a go at reproducing the issue? It would be a huge help to us!

Alternatively, I would like to suggest joining our Discord server, and we could pick up the discussion (and any further details) there. Other members of the community will also be there, and may be able to provide more insight on the issue as well.

Not to mention, thanks so much for taking the time to highlight this issue and providing such in-depth replies!

Here you go. Happy to help.
Just joined Discord as Kory. Talk there in the lottie-after-effects channel.

(Attachment WebMainBkgd_kj4a is missing)

I have the same problem, I haven’t found a solution for hours. Please help me


please help me. i have attached my problem

Hi @anwar.ultramarine

A few things to try:
Check and make sure that you enabled “Allow Scripts to Write Files and Access Network” in After Effects settings under 'Scripting & Expressions’


Install ZXP file manually.

  1. rename your .zxp file to .zip
  2. unzip the zip file
  3. drag that unzipped folder into the folder (on PC)
    C:\Program Files (x86)\Common Files\Adobe\CEP\extensions\
  4. Create a registry entry “PlayerDebugMode” with String value 1 in
    (To create and modify registry entries you can search for the program “regedit” in the windows menu)