AEGP Plugin PNGIO library error when rendering

Never had this issue before but now when i try to render a animation that has either a PNG?JPG i get the following error:
Screenshot 2022-01-28 at 14.26.25

Then when I press OK I get a second message whioch says:
AEGP Plugin PNGIO Support: Unable to create PNGIO. ( 5027 :: 12)

Ive tried:

  • Resaving the PNGs
  • Checked the Colour profile is same
  • reinstalling AE

Can anyone help?
Thanks

3 Likes

This might be a weird question, but is the JPG or PNG exported as sRGB, Adobe RGB 1998, or CMYK?

1 Like

Exported as JPG or PNG, and sRGB.

I’ve found the only fix is going back to After Effects 2021 (18.4.1) instead of working in AE 2022

2 Likes

Oh wild! I wonder if the devs need to know about that problem in 2022 AE. I haven’t updated to 2022 yet… and… I’m going to wait :wink:

1 Like

Also having this issue. Has anyone heard anymore on this?
I am on OSX Monterey 12.2.1
M1 Max Chip
AE 2022 22.2.1 (build 3)

1 Like


Same. MacBook Pro. M1 MX. Monteray.

I can confirm this also worked for me. Thanks @rsweetmore. The issue lies with AE/22. Hopefully a fix in the near future.

For users facing PNGIO issues, it’s an issue with Adobe AE from version 22.0.1 onwards. The workaround for now is to downgrade After Effects to 22.0.1. Adobe will update this post when a fix for their render queue is available.

Hey folks!

For those who’ve been getting the PNGIO error while rendering (AE v22.0.1 onwards), we have a settings fix that would help without downgrading your AE version!

  1. Go to File > Project Settings
  2. Go to Color > on the Working Space dropdown select Apple RGB

This has been tested internally and it should work with our AE plugin v1.2.0 you can download it here: sendanywhe.re/GX1S8UHH

It’s not officially released yet, please feel free to test it out and we would love to hear some feedback before we officially roll it out. Many thanks!

1 Like

Thank you haleeza! I had a this error popup when exporting from After Effects using GifGun and keeping alpha. Thanks! :smile:

As I’ve noticed that problem occurs when you try to render ACES or other color space file into an SRGB project. Change the Working Space to “none” into Project Settings and that should solve the issue.