Hosted Lottiefiles not working in Safari

Lottiefiles hosted on lottiefiles.com working fine in Firefox and Chrome but breaks in Safari. It’s as if some layers get stuck in Safari. This happens when viewing the animation directly on the Lottiefiles website and also when embedding that animation in my own website. The issue in Safari appears both on Mac, iPad and iPhone.

I’ve tried exporting from After Effects using both the Lottiefiles plugin and Bodymovin. No difference.

Mac OS 12.2.1
AE v 22.2.1
Lottiefiles plugin (tried both 1.0.0 and 1.1.0)
Bodymovin 5.8.1

Here are recordings from Firefox and Safari so you can see the difference.

Here’s a link to the hosted animation

Please help

Hey @anna

So I’ve run into this before with Safari. Are you using Alpha Matte or Alpha Inverted Matte? Do you have a lot of layers in Pre-Comps? Also, you can PM me if you want to share files and I can diagnose with you.

1 Like

Hi @irbypace

Thank you! That is so kind of you. No precomps. I’m using Set Matte (alpha). I’m quite a newbie at both AE and LottieFiles so please bear with me :blush:

I’ve messaged you the AE file. Please let me know if you need any other info. Really appreciate your help.

Hello @anna
Here is the solution! You need to remove the path animation (attached screenshot) from the aep ( source file ) and use transform effect instead of path animation. Hope this might help you.
Please check the preview

cheers!

1 Like

Hello @manoj.developer007

Oh, thank you for clarifyiing this and for showing me on the screenshot… I will try and report back. I really appreciate you taking time to help me.

Cheers

1 Like

SOLVED by @irbypace :raised_hands:t4:
Replace Set Matte Effect with Track Matte (alpha).

3 Likes