Alpha Inverted Matte iOS problem

So I have been dealing with this issue for a few months now and still have not found a cause to the problem. I’ve been working on simple animations that are using alpha inverted matte layers. I double checked to make to make sure that alpha inverted mattes are supported before building the animations. But for some reason the animation is not playing correctly on the LottieFiles iOS app. The alpha inverted matte is not displaying as intended. On android, iOS mobile browsers and desktop the animation plays correctly. Here is a link for one of the animations. https://lottiefiles.com/share/mhcGYB

Here is a screenshot of one of my animations on iOS. You can see that the edges of the alpha inverted matte layers are blurry and pixelated. This screenshot is from a different animation not the one linked above. Though the animations have the same alpha inverted matte effect.

I should also note that I did test the animation on another Lottie player iOS app called Lottie Samples. This test worked as the animation did not display the blurring artifacts like the screenshot above. Test the animation link on this app for yourself.

I tried using mask paths instead of track matte layers but that doesn’t work for this particular animation. So maybe the LottieFiles iOS app has a bug in this particular case? Since my second iOS app test proved to work fine then this is the only conclusion I can come up with. Please tell me your thoughts.

For whoever can fix it, please give this issue more attention. It’s such a pain to not have inverted alpha mattes. On iOS this is still an issue. With web and android, it works just fine.
The only way to get around it currently is by exporting a png sequence of the invert and using that as a regular alpha matte which is very unpractical for several reasons.

1 Like

Hey @panews7 thanks for including your workflow to get around this issue. It does seem unpractical but it works for now. I am still dealing with these issues as well, I have already discussed this specific issue with some engineers but I still haven’t found a specific reason why this is only happening on iOS. There is another iOS app that will allow you to test preview your Lottie JSON files. It’s called Animotion X, it’s for iPad specifically but it does offer another way to test your animations and gather more data. This alpha inverted matte issue does not appear when I test my animations using Animotion X. So I’m thinking if this issue is related to the LottieFiles app itself.

1 Like

This is very good to know, thank you for pointing this out!

1 Like

I too noticed this when I was making a bunch of animations, that the web and everything else looked great, but the IOS app was messing them all up. Hopefully this can get fixed up.

1 Like