How to stop playing animation in dotlottie on the last frame?

If I connect the animation in json format, then by default it will stop on the last frame, as I need it to.
But if I use a lighter .dotlottie file, the animation stops at the first frame, not the last, and I have an empty first frame. Therefore, there is a feeling that the animation simply disappears.

How do I make the animation stop or pause on the last frame or before the last frame?

I have already read all the documentation and tried different options with the script like that:

        player: '#firstLottie',
        mode: 'play',
        actions: [
            visibility: [0,1],
            type: 'stop',
            frames: [754],

it doesn’t work, the animation stops at the first frame

1 Like

I can’t seem to find this anywhere online either. It seems like this would be a common enough use that would be easy to look up.

Hey @beau,

It should stays on the last frame if autoplay=true and loop=false

here’s an example: